iMagicSoft Support Forum Index iMagicSoft Support
iMagic Software Support
 
  SearchSearch   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Shuffling fields on item import

 
Post new topic   Reply to topic    iMagicSoft Support Forum Index -> iMagic Inventory Software
View previous topic :: View next topic  
Author Message
imagicsupport
Site Admin


Joined: 16 Dec 2006
Posts: 2144

PostPosted: Tue Apr 04, 2017 9:18 am    Post subject: Shuffling fields on item import Reply with quote

Hi John-I'm trying to import a revised inventory from excell. The native file looks like it should work but when imported it adds tax rates and categories by shuffling the cells around. I'm getting frustrated with it and can't seem to figure out why. I have attached the file I'm trying to import can you offer some guidance with this please. What am I doing wrong?

Jon
Back to top
View user's profile Send private message Visit poster's website
imagicsupport
Site Admin


Joined: 16 Dec 2006
Posts: 2144

PostPosted: Tue Apr 04, 2017 9:20 am    Post subject: Reply with quote

Hi Jon,

Thanks for the reply and details. (note to readers of the forum, you will not be able to see the attachment, it was a CSV file exported from Excel)

The issue is that you're using a Comma Separated File to import but you have commas in the description (ie KWCH-P-SS). So the import is getting confused importing into the wrong column. You can either remove the commas from any text (item names, descriptions etc) or you can change the comma "," separation to a semi-colon ";" (probably easier).

To change to a semi-colon on Windows 10:
- In the Startbar (where it says 'ask me anything') type 'Region' without the quotes. You want to open 'Region - Control Panel'.
- Under the Formats tab click 'Additional Settings'.
- Change the List separator from a comma ',' to a semi-colon ';'.
- Click OK to save.

You'll need to re-export from Excel (you may have to restart Excel) but that should then export using Semi-Colons, then when importing into iMagic Inventory change the 'Field Separator' from a Comma to a Semi-Colon.

Regards, John
_________________
iMagic Soft Support
Back to top
View user's profile Send private message Visit poster's website
imagicsupport
Site Admin


Joined: 16 Dec 2006
Posts: 2144

PostPosted: Tue Apr 04, 2017 9:51 am    Post subject: Reply with quote

Hi John-Just wanted to thank you for your help. I got the inventory in but I need to set a default tax rate from my list of seven county ax rates. How can I do this and apply it to all the items so that when they are selected and added to an invoice they automatically have the correct one with out clicking and changing each item? Or is there a way to change the tax rate for an entire invoice after items are added? Thanks
Back to top
View user's profile Send private message Visit poster's website
imagicsupport
Site Admin


Joined: 16 Dec 2006
Posts: 2144

PostPosted: Tue Apr 04, 2017 9:53 am    Post subject: Reply with quote

Hi Jon,

Thanks for the reply.

At present, there isn't an option to change all the tax rates of items added to an invoice. You can change all the Price Lists for the current invoice though under 'Invoices > This Invoice > Change Price List'. So if you're wanting a new 'Change Tax Rate' feature we could add that in for you.

You could import the appropriate tax rate. If you set up the tax rates under Configure > Tax Rates first. Then in your CSV file set the 'Tax Rate' column to the tax rate name from the configuration, it will find it in the import. I can see how my description might be confusing, let me make a list of steps:

1) Select Configure > Tax Rates and enter your tax rate information. Note the name being used for each tax rate.
2) Export your existing inventory File > Export Inventory.
3) Open the export in Excel and either change the 'Item Tax Rate' column to the name of the tax rate you've set in step 1 above or add in a new column. Export the inventory to a CSV file (File > Save As).
5) Backup your database in iMagic Inventory, File > Backup Database. (in case you have an issue with the import you can revert to the backup)
6) Import via File > Import Inventory. Ensure that the Item Tax Rate field is selected and 'Overwrite Items' is selected. If the Item Number is unique you can just import the 'Item Number' and 'Item Tax Rate' fields to avoid any side effects on the import.

You should then find the items are using the tax rate on the import.

Regards, John
_________________
iMagic Soft Support
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    iMagicSoft Support Forum Index -> iMagic Inventory Software All times are GMT + 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
iMagic Inventory Software home page


Powered by phpBB © 2001, 2005 phpBB Group